Action Button Attaching to Graph Unwanted

Hello Forum Friends,

Recently, when I have tables and graph components on a screen, the buttons have been forcing themselves to attach to the graph. I am using the buttons to trigger events in the table but only after the table is completely filled out. I can’t seem to keep the button with the table anymore. Is there a way to keep the button from attaching to the graph? Thanks in advanced.

Richard Punches

Do you mean physically, the location of the button on the screen? If you just drag the components around, you should be able to get them configured however you want. Sometimes it takes some “wiggling” lol. E.g., I can either arrange graph, table and button like so:

giving me this result:

OR like so:

giving me this:

If a component does not “go” where you intended, you may just have to drag it to convince it to get in its proper place. :slight_smile:

I’m not sure if I’ve understood the issue correctly… if not, maybe you could link to the activity?

1 Like

Yes, it is physically forcing itself on my graph. I have multiple buttons on the page controlling feedback for my students but only after they have answered the question. One of the buttons always attaches itself to the graph and I want it controlling the feedback in the tables. The Graph is a readOnly: true. I finally gave up and replaced the graph with an media component image and was able to move the button where I wanted it.

If you’re able to make a version of the activity that had the stuck button and share it, we’d appreciate it. Even posting it in the “bug report” category would be great!

I tried adding a bunch of tables and buttons with a graph, and never had a problem getting the button to not go to the graph (up to 5 tables + buttons), as long as all the tables + buttons were in the other column. (Screen 1)

Then I tried to add a table & button to the SAME column where the graph lived, no dice. Button sticks to the graph! I tried adding in an empty “note” between the 2, but the button still wants to be on the graph. :open_mouth: (S2)

Then I thought I could outsmart the button. :thinking: :stuck_out_tongue_winking_eye: So I added table + button to left column and then added the graph AFTER and BELOW. Button stays with table! :smiley: (S3)

Now that I’ve showed that button whose boss, I thought maybe I could MOVE the graph to the top of the column, above the table. DAMN that pesky button, if it doesn’t jump up to the graph! :exploding_head: (S4)

Also, I seem to be Des-crastinating today… :neutral_face:

Here is the activity.

I’ll also put it in the bug report. I don’t think it is a bug, I think it is just an issue with teachers’ ability to move components around. If there is a button in a column with a graph, it automatically gets grabbed by the graph.

Richard Punches

Super helpful, thanks!