showSubmitButton: false not hiding Submit button

Alright, maybe I’ve been working too long, but I can’t figure out what’s going on here. In slide 10 of my activity
Area Between Curves
I tried to hide the submit buttons on the Checkboxes. I generally like doing my own thing with buttons. But for some reason, even though I specifically have code to hide the Submit buttons, they keep showing up. Can anyone tell me what’s going wrong here?

I don’t think anything looks wrong with your code. Seems like a glitch to me.

Huh. I’ve run into this before. Here’s the CL documentation on that:

showSubmitButton

When true, force show submit button. When false, force hide submit button, unless a source relies on it.

But when it happened to me, I couldn’t figure out what relied on it. Curious if it is a bug!

We’ll take a look. In the meantime, just delete the showSubmitButton sinks in the checkbox components and they should go away.

1 Like

I just ran into the same issue myself. showSubmitButton - bug? • Activity Builder by Desmos

…good call @Jay, I removed the sink entirely and it worked for the case I needed.

@Jay any progress on this? it continues to be a problem

Thanks