Feedback button on multi-select choices

I’m trying to have a Button for kids to click after selecting answers on a multi-select choice.
Once clicking the button, they will then get feedback based on their choices.

Here’s what I’ve started…

:slight_smile:

You can’t have an action button and multi-select on the same slide. You can have a followup slide that gives your feedback though.

Thanks! That’s a good work around.
:slight_smile:

Hey Munnmath, thank you so much for this! I’ve been struggling with it for days and your solution is so simple and elegant :slight_smile:

The action button isn’t available, but you can “turn on” a submit button in CL. In the choice component, type in submitLabel: "Submit". You will need to reference the button in your note component, otherwise it still won’t show up. Here’s an example

1 Like

Thanks Craig!
Here’s an updated version (that I’m going to use) with a submit button. It gave just the right amount of pause before showing the feedback!

1 Like

Hey Noa,
It now has a submit button!
:slight_smile:

I just tried this slide. However, when I tested an incorrect answer and tried to ‘edit my response’, I could not longer select either of my first two responses, even though one of them was correct. How do I reset the question for the second attempt?

I didn’t have the choosing problem, but if you only choose 1 answer it just continues to display the directions. I cleaned up the correctness check a bit by nesting conditionals. Here ya go:

Edit: Oops, you might want to change the feedback text for the 1 or 2 to something like “You’ve got at least one right, but something is wrong.” since it won’t account for choosing 1, 2, and 3.

Thanks @Daniel_Grubbs! That would definitely be the simpler way.

I just finished cleaning it up a bit with variables for the answer choices and also included all the possible combinations (with varied feedback based on choices).
@cindyk As for resetting for the subsequent attempts, you just need to to de-select your previous choice(s). I can’t seem to find any CL to reset the multi-select. (Wish I could though)

I updated the original version:

I have primarily been using Edge as my browser and I have to refresh the page for the checkboxes to reappear. It works as you describe when I use Chrome. Any ideas why that is?

Hey Cindy! That might be a bug, can you email me in detail what’s going on here? Ideally, what happens on chrome vs what happens on edge along with a link to the screen? Jay@desmos.com. Thanks!

https://teacher.desmos.com/activitybuilder/custom/5e7acef0dd45d46876ef5ad2

My background is in computer science so I’m used to troubleshooting.