CL Error Workaround?

I’m building an assessment template and I’m trying to set it up so that the teacher who uses it has to edit as little CL as possible. There is a “setup” component on the 1st slide.

The issue is that sometimes the teacher will have more questions/slides and sometimes they will have less. This cause certain CL errors to appear.

On the last slide I am able overcome these errors to get the value I want in the graph but I am unable to pull that number into CL. Please help! Thank you : )

Maybe someone else can see I way, but I don’t think you can overcome having references to undefined components. I think the easiest way is to show the teacher how to delete the relevant lines from the CL. That shouldn’t be too hard? They just need to delete a chunk of lines from the last slide.

Since your c’s are binary, if you change your definition of C, this will ignore all your undefined sinks:

The errors will still show, but aren’t relevant to it functioning.

1 Like

Sadly no luck with that workaround. In my mind that should work (as should me original method) but the activity still doesn’t want to recognize that number.

I swore it worked when I tried it! Must’ve left the components in or something. I also tried firstDefinedValue(c4, 0), but no luck there either. The lack of component totally breaks it.

1 Like

Yeah it’s super weird. Especially since the number appears in the graph!