Correctness not working

I’m not sure what I am doing wrong. The dashboard won’t show slides 13-16 as being correct. I have readOnly:true on the sketch. It doesn’t let me put it anywhere else. Any way to fix it?

You cannot get a checkmark in the dashboard if…

  1. You are missing a correct: sink or readOnly: true where it is available. (At least one correct sink needed as well)
  2. You have a text input or explainPrompt (it’s assumed a teacher needs to review for the slide to be correct). This appears to be your issue.
  3. Your correct sink is with a component students don’t actually interact with. (Best practice is correct sink in the component where the work is entered.
1 Like

Thanks.

Is there a way for the dashboard to ignore text input?

You said the correct sink should be on the input component. Mine are on the math input components. I’m not sure what you were trying to say by your 3rd point.

There is not a way to ignore a text input or explain prompt. You can use a table for entry and ignore a table, but the space is limited.

Sometimes people put a correct sink, in a graph CL for example, but it refers to the student’s answer in a math input to determine correctness. If the student doesn’t actively use the graph, it will not “activate” the correct sink, so it’s best to always correct something in the component the student uses. If they type in a math input or table, have a correct sink in the math input or table, respectively. If you have more than one input, have a correct sink for each one.

Right. I have that part.

Thanks for the help!

Have they added a feature yet to ignore the explain prompt on a multiple choice component? Is there a way to add a correct sink that just checks to see if something was entered in the explain box?

You can correct multiple choice for students, but it will not show on the dashboard. I don’t know if they are working on it.

You can also add a correct sink to an input box, but I am not sure that you can do that for an explain box.

1 Like

You actually can get a Checkmark on the Teacher Dashboard even with Text Input from a Multiple Choice.

The key is to not use a Text Input component and not to select the Ask student to explain their answer option. Instead, include the following in the Multiple Choice component: showExplain: true

Looks like this:
correct

Check it here: Text Input Correctness • Activity Builder by Desmos

Just an fyi this behavior is likely to change soon to match our other correctness conventions.

That’s really very unfortunate. I think if you’d ask users, they would strongly urge you not to make this breaking change.